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1. Remove Telephony Dependency 

 

 Purpose and Reason 

☞ If Telephony Dependency is not turned off, Samsung Application that includes TSP Driver may not 

work well. To avoid this situation, this case is strongly recommended before installing TSP included 

application.   

☞ This case is only applied for TAPI based application.(TSP included Application) 

 Applied Solution 

☞ Samsung Communicator 

☞ OfficeServ Operator  

☞ OfficeServ OpenTSP 

☞ OfficeServ RCC Gateway 

☞ Any Application which includes TSP driver  

 How to turn off Telephony Dependency on your computer. 

☞ Open [Control Panel -> Administrative tools -> Services] and Choose “Remote Access Connection 

Manager” 

☞ Open its serviced properties 

 Startup Type: “Disabled” 

 To apply this change, reboot the computer.  

 

 

 

 



2. Turn Off  “User Access Control” 

 

 Purpose and Reason 

☞ When UAC Mode is turned on, you have to get the valid permission (actually, administration 

permission) from the system whenever your application tries to access and change the system 

resource like registry, system folder and others. If application doesn’t have the valid permission, it 

may not work well. To avoid this situation, it is recommended to turn off UAC mode before 

installing or using Application. 

 Applied Application 

☞ All Applications 

 How to turn off UAC mode 

☞ Open [Control Panel -> All Control Panel Items -> User Account Control 

☞ Click “Change User Account Control settings” 

 Change the Level to “Never notify” 

 

 

[ Some OS version like Windows Server 2008 Enterprise have the different method for this property] 

☞ Control Panel -> Classic View -> User Accounts -> Turn User Account Control on or off 

 “Windows needs your permission to continue” -> Click “Continue” 

 Use User Account Control(UAC) to help protect your computer -> Remove Check 

 Restarting Computer. 

 



3. Change Internet Information Service Option 

 

 Purpose and Reason 

☞ To run IIS Web Server based application 

 Influenced Solution (Web Service based application) 

☞ OfficeServ DataView 

☞ OfficeServ Messenger 

☞ OfficeServ Easyset 

☞ OfficeServ RCC Gateway 

☞ Samsung Application Suite 

 How to change 

[For Windows 7] 

☞ Control Panel -> All Control Panel Items -> Programs and Features  

☞ Click “ Turn Windows features on or off” 

☞ Find “Internet Information Services” and check under list 

☞ Web Management Tools -> IIS 6 Management Compatibility 

 IIS 6 Management Console 

 IIS 6 Scripting Tools 

 IIS 6 WMI Compatibility 

 IIS Metabase and IIS 6 configuration compatibility 

☞ Web Management Tools -> IIS Management Console 

☞ Web Management Tools -> IIS Management Scripts and Tools 

☞ Web Management Tools -> IIS Management Service 

☞ World Wide Web Services -> Application Development Features 

 .NET Extensibility(Check automatic) 

 ASP 

 ASP.NET 

 ISAPI Extensions(Check automatic) 

 ISAPI Filters(Check automatic) 

☞ World Wide Web Services -> Common HTTP Features 

 Default Document(Check automatic) 

 Directory Browsing 

 HTTP Errors 

 Static Content 

☞ World Wide Web Services -> Health and Diagnostics 

 HTTP Logging 



☞ World Wide Web Services -> Security 

 Basic Authentication 

 Request Filtering(Check automatic) 

 Windows Authentication 

 

 

[For Windows Server 2008] 

☞ Control Panel -> Administrative Tools -> Server Manager -> Left side Click ” Roles” -> Right side 

Click “Add Roles” 

 

☞ Add Roles Wizard -> Click “Next” -> Check “Web Server(IIS)” -> Click ”Add Required Features”  -> 

Click “Next” -> Click “Next” 



 

☞ Web Server -> Common HTTP Features 

 Static Content (Check default) 

 Default Document (Check default) 

 Directory Browsing (Check default) 

 HTTP Errors (Check default) 

☞ Web Server -> Application Development 

 ASP.NET -> Click ”Add Required Role Services” 

 .NET Extensibility (Check automatic) 

 ASP 

 ISAPI Extensions (Check automatic) 

 ISAPI Filters (Check automatic) 

☞ Web Server -> Health and Diagnostics 

 HTTP Logging (Check default) 

 Request Monitor (Check default) 

☞ Web Server -> Security 

 Basic Authentication 

 Windows Authentication 

 Request Filtering (Check default) 

☞ Web Server -> Performance 

 Static Content Compression 

☞ Management Tools -> IIS Management Console (Check default) 

☞ Management Tools -> IIS Management Scripts and Tools 

☞ Management Tools -> IIS Management Service 



☞ Management Tools -> IIS 6 Management compatibility  

 IIS 6 Metabase compatibility 

 IIS 6 WMI Compatibility 

 IIS 6 Scripting Tools 

 IIS 6 Management Console 

 

☞ Click “Next” -> Click “Install” 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



4. Change “Web Server Properties” 

 

 Purpose and Reason 

☞ To run IIS Web Server based application.  

 Solution (Web Service based application) 

☞ OfficeServ DataView 

☞ OfficeServ Messenger 

☞ OfficeServ Easyset 

☞ OfficeServ RCC Gateway 

 How to change 

☞ Control Panel -> All Control Panel Items -> Administrative Tools -> Internet Information Services(IIS) 

Manager 

☞ Double Click, Left side System name -> Click “Application Pools” 

☞ Click, Middle side “DefaultAPPPool” -> Click, Right side “Advanced Settings…” 

 

☞ Advanced Settings -> General  

 "Enable 32-Bit Applications" :  TRUE (This item will be applied on 64bit OS only) 

 "Managed Pipeline Mode" : Classic 

    

☞ Right side “Application Pool tasks” -> Click “Stop” -> Click “Start”  



5. Install use “Troubleshoot compatibility” 

 

 Purpose and Reason 

☞ Windows 7 or Windows 2008 OS allows user to run the old application that are developed on XP or 

other OS as one of backward compatibility.  

☞ We strongly recommend you to use this option before using Samsung Solution.  

 Influenced Application 

☞ All Applications 

 How to change 

☞ Usage for this feature depends on the OS version 

☞ Right Click on Setup PKG -> Click “Troubleshoot compatibility” 

 

☞ Click “Troubleshoot Program” -> Check “The Program Worked in earlier versions of Windows….” 

 

☞ Click “Windows XP(Service Pack2)” or “Windows XP(Service Pack3)” -> Click “Next” -> Click “Start the 

Program…” 

 

☞ Install Program 

☞ End Install, Click “Next” -> Click “Yes, save these settings…….” 

 

☞ Click “Close the troubleshooter” 



6. “Troubleshoot compatibility” About Run Program 

 

 Purpose and Reason 

☞ Windows 7 or Windows 2008 OS allow user to execute the old application via this feature. 

☞ We recommend you to use this feature before running Samsung Application.  

☞ Usage of this feature depends on OS version. 

 Influenced Application 

☞ All Applications 

 How to change 

☞ Right Click on Run icon -> Click “Troubleshoot compatibility” 

 

☞ Click “Troubleshoot Program” -> Check “The Program Worked in earlier versions of Windows….” 

 

☞ Click “Windows XP(Service Pack2)” or “Windows XP(Service Pack3)” -> Click “Next” -> Click “Start the 

Program…” 

 

☞ Install Program 

☞ End Install, Click “Next” -> Click “Yes, save these settings…….” 

 

☞ Click “Close the troubleshooter” 



7. How to configure SQL Server 2008(or Express) for Samsung Solution 

 

 Purpose and Reason 

☞ To use SQL Server 2008 for Samsung Solution based on SQL Server 

 Influenced Application 

☞ OfficeServ DataView 

☞ OfficeServ Messenger 

☞ Any Application that uses SQL Server 2008(or Express) 

 How to use 

☞ See the bellowed detailed progress for each OS and SQL version 

 

 OS Type  

Microsoft Windows 2008 Server x86 Edition or Microsoft Windows 7 x86 Edition(32 bits OS) 

 Items to be checked before installation. 

☞ Run “Windows Update” until there is no update. 

[Only for Windows 2008 Server x86 Edition] 

☞ Download “Microsoft .Net Framework 3.5 SP1” and install it 

 http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=ab99342f-5d1a-

413d-8319-81da479ab0d7 

[Only for Windows 2008 Server x86 Edition] 

☞ Download “Windows Installer 4.5” and install it 

 http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=5a58b56f-60b6-

4412-95b9-54d056d6f9f4 

 Download “Windows6.0-KB942288-v2-x86.msu” and install it. 

☞ Install “Microsoft SQL Server 2008 Server(or Express Edition SP1 as Free Version)” 

 http://www.microsoft.com/downloads/details.aspx?familyid=01AF61E6-2F63-4291-BCAD-

FD500F6027FF&displaylang=en 

 Download “SQLEXPR32_x86_ENU.exe” and install it (it is only available for 32 bit OS) 

 [Database Engine Configuration -> Account Provisioning -> Authentication Mode] ->      

Choose “Mixed Mode(Windows Authentication and SQL Server Authentication)” and Enter           

password for sa account 

[Only for Windows 2008 Server x86 Edition] 

☞ Install “Windows PowerShell 1.0” 

 Control Panel -> Administrative Tools -> Server Manager -> Left side Click ” Features” -> Right 

side Click “Add Features” 

 Check “Windows PowerShell” -> Click “Next” -> Click “Install” 
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☞ Install “Microsoft SQL Server 2008 Management Studio Express” 

 http://www.microsoft.com/downloads/details.aspx?familyid=08E52AC2-1D62-45F6-9A4A-

4B76A8564A2B&displaylang=en 

 Download “SQLManagementStudio_x86_ENU.exe” and install it 

 For Windows 7 and Windows Server 2008 R2, the install process displays the “Program 

Compatibility Assistant” dialog indicating that you must apply SQL Server 2008 Service Pack 1 

or later. Select the option to “Run Program” to continue.  

☞ Install Microsoft SQL Server 2008 Feature Pack 

 http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=b33d2c78-1059-

4ce2-b80d-2343c099bcb4 

 Search “Microsoft SQL Server 2005 Backward Compatibility Components” 

 Download “X86 Package (SQLServer2005_BC.msi)” and install it 

 Feature Selection -> Install SQL Distributed Management Objects(SQL-DMO)  

 

 OS Type 

Microsoft Windows 2008 Server x64 Edition or Microsoft Windows 7 x64 Edition (64 bit OS) 

 Items to be checked before installation. 

☞ Run “Windows Update” until there is no update. 

☞ Allow to use “ASP.net 32bit Mode” and run the following. 

 Start-> All Program -> Accessories -> Command Prompt -> Right Click on Icon -> Click “Run 

as administrator” 

 cscript %SYSTEMDRIVE%\inetpub\adminscripts\adsutil.vbs                                   

SET W3SVC/AppPools/Enable32bitAppOnWin64 1 

 if no problem, you can see the following message  

“Enable32bitAppOnWin64 : (BOOLEAN) True” 

 [Only for Windows 2008 Server x64 Edition] 

☞ Download “Microsoft .Net Framework 3.5 SP1” and install it 

 http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=ab99342f-5d1a-

413d-8319-81da479ab0d7 

[Only for Windows 2008 Server x64 Edition] 

☞ Download “Windows Installer 4.5” and install it 

 http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=5a58b56f-60b6-

4412-95b9-54d056d6f9f4 

 Download “Windows6.0-KB942288-v2-x64.msu ” and install it. 

☞ Download “Microsoft SQL Server 2008 Server(or Express Edition SP1 as Free Version)” and install it 

 http://www.microsoft.com/downloads/details.aspx?familyid=01AF61E6-2F63-4291-BCAD-
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FD500F6027FF&displaylang=en

 Download “SQLEXPR_x86_ENU.exe” and install it (Apply 32bit and 64bit(WoW) OS) 

 

 Database Engine Configuration -> Account Provisioning -> Authentication Mode ->      Click 

“Mixed Mode(Windows Authentication and SQL Server Authentication)” -> input password 

(using Login account “sa”) 

[Only for Windows 2008 Server x64 Edition] 

☞ Install “Windows PowerShell 1.0” 

 Control Panel -> Administrative Tools -> Server Manager -> Left side Click ” Features” -> Right 

side Click “Add Features” 

 Check “Windows PowerShell” -> Click “Next” -> Click “Install” 

☞ Install Microsoft SQL Server 2008 Management Studio Express 

 http://www.microsoft.com/downloads/details.aspx?familyid=08E52AC2-1D62-45F6-9A4A-

4B76A8564A2B&displaylang=en 

 Download “SQLManagementStudio_x64_ENU.exe ” and install it. 

 For Windows 7 and Windows Server 2008 R2, the install process displays the “Program 

Compatibility Assistant” dialog indicating that you must apply SQL Server 2008 Service Pack 1 

or later. Select the option to “Run Program” to continue.  

☞ Install Microsoft SQL Server 2008 Feature Pack 

 http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=b33d2c78-1059-

4ce2-b80d-2343c099bcb4 

 Search “Microsoft SQL Server 2005 Backward Compatibility Components” 

 Download “X86 Package (SQLServer2005_BC_x64.msi)” and install it 

 Feature Selection -> Install SQL Distributed Management Objects(SQL-DMO)  

 

 How to allow user to access SQL Server on remote PC 

☞ SQL Server Configuration Manager(Local) -> SQL Server Network Configuration -> Protocols for 

MSSQLSERVER 

 Shared Memory   : Enabled 

 Named Pipes      : Enabled 

 TCP/IP            : Enabled 

 VIA              :  When MSSQLServer is Disabled / When SQLEXPRESS is Enabled 

☞ SQL Native Client 10.0 Configuration -> Client Protocols 

 Shared Memory  : Enabled 

 Named Pipes     : Enabled 

 TCP/IP           : Enabled 

 VIA             : Disabled 
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Appendix:  Setting Items for Each Solution 

 

A. Install OfficsServ DataView (SQL DB) 

 

 Items to be checked before installation. 

☞ Run “Windows Update” until there is no update. 

☞ Default Setting 

 Check IIS Web Setting by referencing chapter 3,4 

If you are installing DataView SQL version, see first chapter 7.(How to configure SQL Server…) 

 Install 

☞ Install use “Troubleshoot compatibility” 

 Install use “Troubleshoot compatibility” reference chapter 5 

 

 Notice DataView Install on Microsoft Windows 2008 Server (x86 / x64) Edition 

☞ You have to OWC(Office Web Components) mode separately.  

 t the last step of DataView installation, Setup package will prompt OWC(Office Web 

Components) Installation Option.  

 At this step, do not install OWC Module and quit the installation of DataView. If not, you can 

get the error message regarding the installation failure. However, you can ignore it.   

 Go to the below web site and download the latest OWC Module.  

 http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=7287252c-402e-

4f72-97a5-e0fd290d4b76 

 Run the latest OWC module with “the troubleshoot compatibility mode” 

 

 Checklist after Install 

☞ Control Panel -> All Control Panel Items -> Administrative Tools -> Internet Information Services(IIS) 

Manager 

☞ Double Click, Left side System name -> Double Click “Sites” -> Double Click “Default Web Site” -> 

Click “DataView” 

 IIS -> Double Click “ASP” -> Enable Parent Paths : True 

http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=7287252c-402e-4f72-97a5-e0fd290d4b76�
http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=7287252c-402e-4f72-97a5-e0fd290d4b76�


 

 

☞ Allow to use ActiveX for your web page. (for allowing Chart View) 

 Control Panel -> All Control Panel Items -> Internet Options -> Tab “Security” -> Local intranet 

-> Click “Custom Level…” 

 ActiveX controls and plug-ins -> Initialize and script ActiveX controls not marked as safe for 

scripting -> Change “Prompt” 

☞ To use Excel export feature of DataView, Microsoft Excel should be installed on the computer.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



 

B. Migration from OfficeServ IP-UMS to SAS Server 

: Setup and Migrate database procedure 

 

 Backup OfficeServ IP-UMS  

☞ DB backup  

 Execute MS SQL Server Management Studio Express. 

 Login to DB (id/password = ums/ums)  

 Backup IP_UMS DB.  

 

 

 



 

 

 

☞ If you succeed backup DB, you can get xxx.bak file.  

Ex) C:\Program files\Microsoft SQL Server\MSSQL\Backup\IP_UMS.bak  

 

 Backup data files 

☞ Move Prompt, Voicemail, Name, Greeting files to anther directory. It exits below directory. 

C:\program Files\Samsung electronics\OfficeServ IP-UMs\ums\defdata\*.* 

C:\program Files\Samsung electronics\OfficeServ IP-UMs\ums\userdata\*.* 

 

 Install SAS Server. 

☞ Install SAS package. 

 

 Restore  DB & data 

☞ Restore DB  

 Execute MS SQL Management studio Express and select “Restore database” from backup file. 



 

 



 

 

☞ Restore data files 

 Copy data files on the same directory. 

C:\program Files\Samsung electronics\OfficeServ IP-UMs\ums\defdata\*.* 

C:\program Files\Samsung electronics\OfficeServ IP-UMs\ums\userdata\*.* 

 

 DB migration 

☞ execute submig.exe and export subscriber data to user.csv file. 

C:\Program Files\Samsung Electronics\OfficeServ IP-UMS\bin_uc\submig.exe 

 

☞ Open User.csv file with MS Excel and input NEW ID then save it. 

☞ Import User.csv file like below. 

 

☞ Open Migration_IP_UMS_NEW_ID_ALL_PRETEST.sql file on the MS SQL Server Management Studio.  

Script file exists below directory.  

C:\Program Files\Samsung Electronics\OfficeServ IP-UMS\bin_uc  

 



☞ Click Execute button for migration db data. 

 

☞ If there is no error in the Results window, open Migration_IP_UMS_NEW_ID_ALL_COMMIT.sql file 

and execute again. 

 

 If you finish DB migration, delete IP_UMS DB. 

 

 

C. Upgrade Messenger Server to SAS Server 

 

1. Backup old Messenger server data. 

☞ Backup database in the SQL Server Management tool. 

 (Database name : OFFICESERV_UC)  

☞ Old Messenger server data/configuration files. 

 C:\Program Files\Samsung Electronics\OfficeServ Messenger Server\*.* 

 C:\Program Files\Samsung Electronics\OfficeServ Messenger Server\mlog\*.* 

 C:\Program Files\Samsung Electronics\OfficeServ Messenger SIMPLE Gateway Server\*.* 

 C:\Program Files\Samsung Electronics\OfficeServ Messenger XCAP Server\*.* 

☞ license key for OfficeServ Messenger Server in the Web admin. 

 

2. Uninstall old Messenger Server suite. 

☞ OfficeServ Messenger Server 

☞ OfficeServ Messenger Simple Gateway Server 



☞ OfficeServ Messenger XCAP Server 

 

3. Reboot the system. 

 

4. Install SAS with Messenger. 

 

 

5. Restore old Messenger data. 

☞ Copy mlog folder in the backup folder to the new OSM folder. (c:\Program Files\Samsung 

Electronics\UCMServer\OSM\mlog) 

6. Change firewall settings. 

☞ OSM\MSPS.exe, OSM\WBMSrv.exe, SIMPLE\GATEWAY.exe, XCAP\XCAPServer.exe 

7. Restore Database 

☞ If the OFFICESERV_UC database does not exists, restore it in the SQL Server Management tool   

(use 1.1) 

8. Run migration SQL Script 

☞ Open migration script file for OSM (OSM_Migration_General_100713.sql) 



 

☞ Click Execute icon(  ) or press F5 button. 

☞ Check result message in the message window. 

 

9. Login Admin web page. 

☞ ID : admin 

☞ Password : 1234 

 

10. Input license key in the admin web page and save. (Solutions – Messenger) 



 

 

11. Start Messenger Service. 
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